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Techniczne wskazówki bezpieczeństwa 
Podręcznik ten zawiera wskazówki, których powinieneś przestrzegać dla w asnego
bezpieczeństwa oraz w celu uniknięcia uszkodzenia sprzętu. Wskazówki te oznaczono 
specjalnym trójkątem ostrzegawczym i w zależności od stopnia zagrożenia następująco 
opisano: 

Niebezpieczeństwo 
Oznacza zagrożenie śmiercią, poważnym uszkodzeniem cia a lub dużymi stratami, jeśli nie 
będzie przestrzegać się odpowiednich zasad bezpieczeństwa. 

Ostrzeżenie 
Oznacza możliwość wystąpienia zagrożenia śmiercią, poważnym uszkodzeniem cia a lub 
dużymi stratami, jeśli nie będzie przestrzegać się odpowiednich zasad bezpieczeństwa. 

Uwaga 
Oznacza możliwość wystąpienia lekkiego uszkodzenia cia a lub strat, jeśli nie będzie 
przestrzegać się odpowiednich zasad bezpieczeństwa. 

Wskazówka 
To ważna informacja o produkcie, jego użytkowaniu lub wskazanie szczególnie ważnej części 
dokumentacji. 

Wykwalifikowany personel 
Instalacja i użytkowanie sprzętu może przeprowadzać tylko wykwalifikowany personel. W 
rozumieniu tego podręcznika wykwalifikowany personel to osoby uprawnione do pod ączania, 
uziemiania i oznaczania urządzeń, systemów i obiegów prądu zgodnie ze standardami 
bezpieczeństwa  

Użytkowanie zgodnie z przeznaczeniem 
Należy przestrzegać co następuje: 

Ostrzeżenie 
Urządzenie może być używane tylko w uk adach przewidzianych w katalogu i w opisie 
technicznym, tylko w po ączeniu z urządzeniami zalecanymi lub dopuszczonymi przez firmę
Siemens obcymi urządzeniami i komponentami. 
Prawid owa i bezpieczna praca urządzenia możliwa jest tylko przy za ożeniu, że nastąpi
w aściwy transport, w aściwe magazynowanie, montaż i prawid owe użytkowanie i 
konserwacja urządzenia. 

Znaki towarowe 
SIMATIC®, SIMATIC HMI® i SIMATIC NET® są zarejestrowanymi znakami towarowymi firmy 
Siemens. Pozosta e oznaczenia w tym tekście mogą być znakami towarowymi, a ich używanie 
przez osoby trzecie dla ich w asnych celów może naruszać prawa w aścicieli. 
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1 Wprowadzenie STEP 7 

1.1 Czego będziecie się Państwo uczyć

Za pomocą praktycznych ćwiczeń pokażemy, jak proste jest programowanie w 
LAD (Ladder Logic), FBD (Function Block Diagram) lub STL (Statement List) 
za pomocą STEP 7. 

Zawarte w poszczególnych rozdzia ach szczegó owe wskazówki pokazują krok 
po kroku szerokie możliwości zastosowania STEP 7. 

Tworzenie programu z wykorzystaniem instrukcji binarnych 

W rozdzia ach 2 do 7 stworzymy program wykorzystując instrukcje binarne. Za 
pomocą instrukcji binarnych będziemy odpytać wejścia i wyjścia sterownika. 

Przyk ady programowania w tej dokumentacji bazują m.in. na trzech 
podstawowych instrukcjach binarnych. 

Pierwsza funkcja binarna, którą będziemy później programować, to funkcja 
AND (iloczyn logiczny). Funkcję AND można zobrazować w obwodzie 
elektrycznym za pomocą dwóch styków. 

     Styk 1       Styk 2 

Druga funkcja binarna to OR (suma logiczna), która także może zostać
przedstawiona w obwodzie elektrycznym. 

Styk 3 

Przy zwartym  
styku 1 i 2 zapala się
lampka 

Przy zwarciu styku 3 
lub 4 zapala się lampka 

Styk 4 
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Trzecia funkcja binarna to funkcja zapamiętywania. Funkcja SR reaguje w 
obwodzie elektrycznym na określone stany napięć i przekazuje je odpowiednio 
dalej.

Po wciśnięciu przycisku S 
lampka pali się do 
momentu wciśnięcia 
przycisku R 

Styk S 

Styk R 

Komórka pamięci 



8

1.2 Wspó praca oprogramowania i sprzętu

Za pomocą programu STEP 7 stworzymy w ramach jednego projektu w asny 
program. Sterownik S7 sk ada się z zasilacza, CPU oraz modu ów wejścia / wyjścia 
(modu y I/O). 

Sterownik swobodnie programowalny (PLC) wykonując program nadzoruje i steruje 
pracą maszyny. W programie poszczególne wejścia i wyjścia modu ów wywo ywane 
są przy użyciu adresów. 

Kabel  do 
programowania 

Programator/Komputer PC 

Przes anie stworzonego 
programu 

Program STEP 7 

Sterowana 
maszyna 

Modu  wyjśćCPU 

Zasilacz Modu  wejść
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1.3  Podstawowe operacje w STEP 7 

Przed rozpoczęciem projektowania, powinni Państwo wiedzieć, iż projekty w 
STEP 7 mogą być tworzone w różnorodnej kolejności postępowania.

Możliwość 1       Możliwość 2 

Za ożyć projekt (Roz.2) 

Stworzyć rozwiązanie systemu sterowania 

Konfiguracja sprzętu 
(Roz.6) 

Konfiguracja sprzętu 
(Roz.6) 

Stworzenie programu 
(Roz.3 do 5) 

Stworzenie programu 
(Roz.3 do 5) 

Przenieść program do CPU i przetestować (Roz.7) 

Przy tworzeniu skomplikowanych programów z dużą ilością wejść i wyjść
polecamy stworzenie najpierw konfiguracji. Zaletą tego sposobu jest 
wskazywanie w edytorze konfiguracji możliwych do wykorzystania adresów 
wejść/wyjść.
W drugim sposobie należy ustalić sobie adresy sterownika w zależności od 
posiadanego sprzętu bez wykorzystania w tym celu konfiguracji w STEP 7.  

Tworząc konfigurację sprzętową ustalone zostają nie tylko adresy 
poszczególnych modu ów, ale możemy także ustalić parametry i zachowanie się
poszczególnych elementów sprzętu. Np. dla systemu sieciowego w którym 
mamy do czynienia z kilkoma sterownikami, możemy ustalić adresy w sieci MPI 
dla poszczególnych CPU.

Ponieważ w tej dokumentacji nie będziemy używali 
dużej ilości wejść i wyjść, pominięta zostanie 
konfiguracja sterownika i przejdziemy od razu do 
programowania.  
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1.4 Instalacja STEP 7 

Niezależnie od tego, czy rozpoczynamy projektowanie od programowania, 
czy też konfiguracji sprzętu, nieodzownym jest zainstalowanie STEP7.  
W przypadku użycia programatora STEP7 jest już w nim zainstalowany. 

Przed instalacją STEP7 na PG/PC 
bez zainstalowanej wersji należy
zapoznać się ze wskazówkami 
dotyczącymi sprzętu i 
oprogramowania. Znajdują się one na 
CD STEP7 w zbiorze Readme.wri. 

W celu zainstalowania STEP7 należy
w ożyć CD. Program instalacyjny 
uruchomi się automatycznie. Należy
postępować wg wskazówek.  

Jeśli program instalacyjny się nie 
uruchomi automatycznie, należy go 
znaleźć na CD pod  
<dysk>:/STEP 7/Disk1/setup.exe 

Po zakończeniu instalacji i 
restartowaniu komputera na 
Windows Desktop pojawi się ikonka 
SIMATIC Manager.  

Podwójne kliknięcie na powsta ą ikonkę SIMATIC Manager powoduje 
uruchomienie edytora STEP7.  

Dalsze informacje dotyczące instalacji 
zawarte są w zbiorze Readme.wri 
znajdującym się na CD STEP7.  



W ramach projektu dane 
przechowywane sà  
w hierarchicznej strukturze
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Wykonując projekt ćwiczeniowy 
wybierz CPU 314. Przyk ad jest tak 
wykonany, że można jednak wybrać
aktualnie posiadany sterownik.  

Wstępnie ustawiany jest adres MPI o 
numerze 2.  

Przejście do następnego okna 
następuje po kliknięciu przycisku Next. 

Każde CPU posiada odpowiednie 
parametry np. dotyczące
rozbudowy pamięci czy też
przestrzeń adresową. Dlatego też
typ CPU należy wybrać przed 
rozpoczęciem programowania.  

Ustawienie adresu MPI (Multi Point 
Interface) wymagane jest do 
komunikacji CPU z PG/PC 

Wybierz blok OB1 jeśli nie jest jeszcze 
zaznaczony.  

Wybierz sposób prezentacji programu: 
(LAD) Ladder Logic – schemat 
drabinkowy, (STL) Statement List – 
lista instrukcji, (FBD) Function Block 
Diagram – logiczne bloki funkcyjne.  

Potwierdź ustawienia za pomocą
klawisza Next.  

OB1 jest g ównym blokiem 
programowym, z którego 
wywo ywane są inne bloki. 

Zmiana sposobu prezentacji 
programu jest możliwa także
później.  
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Kliknij dwukrotnie na nazwę
projektu (pole „Project name”) i 
wprowadź nową nazwę np. 
„Getting Started”. 

Kliknij na przycisk Make  w celu 
wygenerowania projektu wed ug
dokonanych ustawień.

Po kliknięciu na przycisk Make w oknie SIMATIC Manager ukaże się projekt z 
nową nazwą (np. „Getting Started”). Na kolejnych stronach przedstawione 
zostanie znaczenie poszczególnych elementów tworzonej struktury projektu, oraz 
podamy efektywne metody ich wykorzystywania.  

Wizard STEP7 będzie uruchamiany każdorazowo przy uruchomieniu programu. 
Tę w asność można dezaktywować w pierwszym ukazującym się okienku. Jeśli 
chcemy tworzyć projekty bez wykorzystania Wizard, należy tworzyć projekt 
ustawiając każdy z parametrów projektu niezależnie.  

Dalsze informacje znajdują się w  Help 
> Contents "Setting Up and Editing the 
Project”. 
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Wywo ywanie pomocy do STEP 7 

      F1 Możliwość nr 1: 

Zaznacz dowolne polecenie Menu i 
naciśnij przycisk F1. Otrzymasz 
fachową pomoc dotyczącą
zaznaczonego polecenia Menu. 

Możliwość  nr 2: 

Poprzez Menu wchodzisz do pomocy 
do STEP 7. 

W lewym polu okna pokazuje się spis 
treści zawierający różne tematy 
pomocy, a w prawym polu wybrany 
temat. 

Poszukiwany temat znajduje się
przyciskając + w polu Contents. W 
prawym polu okna pojawia się
jednocześnie zawartość wybranego 
tematu.  

Za pomocą Index i Find można
podawać szukane określenia i w ten 
sposób odnajdywać żądane tematy 
pomocy. 

Możliwość nr 3: 

Kliknąć na ikonę ”Start page” w STEP 
7 Online Help, która umożliwia 
wyświetlenie informacji pomocniczych 
wed ug następujących rozdzia ów: 
  - Getting Started with STEP 7; 
  - Configuring & Programming; 
  - Testing & Debugging; 
  - SIMATIC on the Internet 

Możliwość nr 4: 

Kliknij na ikonę pomocy. Kolejne 
kliknięcie na określony obiekt 
aktywuje pomoc. 
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3 Programowanie symboliczne 

3.1 Adresowanie absolutne   

Każde wejście i wyjście posiada adres absolutny wynikający z konfiguracji 
sterownika. Adres ten jest określany bezpośrednio, tzn. absolutnie.  

Adresy absolutne możemy zastąpić dowolnymi nazwami symbolicznymi. 

Modu  wejść
cyfrowych  

Bajt 0 
Bity 0 do 7 

Modu  wejść
cyfrowych  

Bajt 1 
Bity 0 do 7 

Modu  wyjść
cyfrowych  

Bajt 5 
Bity 0 do 7 

Modu  wyjść
cyfrowych  

Bajt 4 
Bity 0 do 7 

Adres absolutny:             I       1.5 

Wejście Bajt 1 Bit 5 

Programowania z użyciem adresów absolutnych 
powinno się używać tylko wtedy, gdy sterownik posiada 
niewiele wejść/wyjść.
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3.2 Programowanie symboliczne  

W tabeli symbolicznej określa się nazwy symboliczne przypisując je adresom 
absolutnym elementów, które mają być używane w programie; np. Wejście 
I0.1 oraz symbol „Przycisk 1” . Nazwy obowiązują w ca ym programie i są
określone jako zmienne globalne.  

Praca w edytorze symboli 

Należy w projekcie zaznaczyć
poziom S7-program(1) i klikając
dwukrotnie ikonkę Symbols 
otworzyć tabelę symboli. 

Początkowo tabela symboli 
zawiera jedynie wstępnie 
zdefiniowaną nazwę bloku OB1. 

Kliknij Cycle Execution i zamień
we w asną nazwę programu np. 
„Main Program”.
Wprowadź w drugiej linii nazwę
symboliczną np. Green Light i 
adres Q4.0. Typ danej zostanie 
dobrany automatycznie. 
Klikając na kolumnę Comment 
możemy wprowadzić komentarze 
do symboli. Wprowadzanie 
nowego wiersza kończymy 
wciśnięciem przycisku ENTER.

Wprowadź w trzeciej linii nazwę
„Red light” oraz adres Q4.1 i 
wciśnij ENTER w celu zakończenia 
operacji. 

W ten sposób możemy przypisać symbole do 
wszystkich używanych w programie elementów.
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Istnieje możliwość kopiowania tabeli symbolicznych (np. z przygotowanego 
projektu).  

     

Zabezpiecz wprowadzone symbole za 
pomocą ikonki Save i zamknij okno. 

Format danej, który w tabeli symbolicznej jest nadawany automatycznie, 
obowiązuje także później w jednostce centralnej. STEP7 umożliwia nadanie 
między innymi następujących typów danych: 

BOOL 
BYTE 
WORD 
DWORD 

Dane tego typu są kombinacją binarną BOOL –1bit do  
DWORD- 32 bity 

CHAR Dane tego typu zawierają dok adnie jeden znak kodu 
ASCII 

INT 
DINT 
REAL 

Te typy umożliwiają prezentację wartości liczbowych (np. 
stosowanych w obliczeniach arytmetycznych) 

S5TIME 
TIME 
DATE 
TIME OF DATE 

Dane tego typu reprezentują różnego rodzaju zmienne 
daty i czasu charakterystyczne dla STEP7(np. ustawienie 
czasu zadanego Timera) 

Więcej informacji znajdziesz w Help->Contents 
w rozdziale „Programming Blocks” oraz 
„Defining Symbols”. 

Obok przedstawiona jest 
tabela symboliczna dla 
programu „Getting 
Started”.  
Ogólnie mówiąc dla 
danego programu 
tworzona jest tylko jedna 
tabela symboliczna bez 
względu na język 
programowania. 
W tabeli symbolicznej 
dozwolone są wszystkie 
znaki specjalne (np. 
polskie fonty) 
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4 Tworzenie programu w bloku OB1  

4.1 Otwarcie edytora LAD/STL/FBD  

Wybór LAD Ladder Logic (zapisu drabinkowego), STL Statement List 
(listy instrukcji), lub FBD Function Vlock Diagram (bloków logicznych) 

W STEP7 możemy tworzyć programy w trzech postaciach: LAD, STL i FBD. 
Praktycznie należy wybrać (także w tym rozdziale) którą postacią się
pos ugujemy.  

FBD (bloki logiczne) 

        ”Przycisk 1”              & 
      ”Zielone”
      
        ”Przycisk 2”            = 
        

LAD (schemat drabinkowy) 

         ”Przycisk1”           ”Przycisk2”      ”Zielone”  

STL (lista instrukcji) 

A         ”Przycisk 1” 
A         ”Przycisk 2” 
=         ”Zielone”

Blok jest otwierany w postaci, która zostanie 
wcześniej ustalona podczas jego tworzenia. Później 
możemy dokonywać zmian ustawiając jedną z w.w 
postaci.  



ZEn01_05_STEP7__LAD_1-9
ZEn01_01_STEP7__STL_1-9

ZEn01_03_STEP7__FDB_1-9
or
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Okno programowania w LAD/STL/FBD 

Wszystkie bloki programowe tworzone są w oknie LAD/STL/FBD. Poniżej 
widoczne jest okno w postaci LAD. 

Umieszczanie 
nowej sieci 

Otwieranie i zamykanie katalogu 
elementów programowych i struktury 
wywo ywania bloków. 

Ważniejsze elementy schematu 
drabinkowego i bloku 
funkcyjnego 

Zmiana języka 
programowania 

Tabela deklaracji parametrów 
oraz zmiennych lokalnych bloku 

Tytu  i komentarz do 
bloku lub sieci 

Linia programu (sieć)

Informacja do wybranego elementu 

Katalog  
elementów (w 
tym przypadku 
LAD) i 
struktura  
wywo ań

Okno z zak adkami wyświetlające
dodatkowe informacje: informacje o 
b ędach, symbolika zmiennych, 
monitorowanie zmiennych, porównanie 
bloków oraz wyświetlanie diagnostyki 
procesowej. 
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Kliknij ??.? i wprowadź nazwę
symboliczną „Przycisk_1”. Zatwierdź
Enterem. 

Wprowadź dla drugiego styku nazwę
„Przycisk_2”.  

Dla cewki wprowadź nazwę
„Zielone_Swiatlo”. 

W tym momencie zosta o zakończone 
tworzenie równania szeregowego. 

Jeśli nie ma żadnych czerwonych 
symboli, zapisz blok. 

Przycisk_1      Przycisk_2             Zielone_Swiatlo 

Symbole będą zaznaczane na czerwono, jeśli np. nie będą
zdefiniowane w liście symbolicznej, lub wystąpi  b ąd sk adni. 

Można także wprowadzić bezpośrednio nazwę symboliczną. Kliknij na 
znak ??.? a następnie wybierz w menu Insert-> Symbol. Znajdź w 
liście odpowiedni symbol. Nazwa dodawana jest automatycznie.  
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Programowanie po ączenia równoleg ego w języku LAD  

Wybierz sieć Network 1 

Wprowadź nową sieć.

Zaznacz aktualną sieć.

Kliknij klawisz styku i cewki na listwie 
narzędziowej. 

Wybierz linię prostopad ą do danej 
sieci. 

Dodaj rozga ęzienie równoleg e.

Dodaj drugi styk normalnie rozwarty 
do rozga ęzienia. 

Zamknij rozga ęzienie (jeśli potrzebne, 
to wybierz dolną strza kę)

Kompletna linia logiczna bez 
wype nionych adresów. 

By dodać adresy symboliczne, należy
powtórzyć procedurę z po ączenia 
szeregowego.  

Dodaj oznaczenia dla styków 
„Przycisk_3” i „Przycisk_4”, a dla 
cewki „czerwone_swiatlo”.  

Zapisz blok. 
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Programowanie przerzutnika SR 

Wybierz Network 2 i dodaj kolejną
sieć

Zaznacz aktualną sieć.. 

Wyszukaj w katalogu w Bit Logic 
element SR.  

Dodaj styki przed wejściem S i R. 

Wprowadź nazwy symboliczne funkcji 
SR.  

Zapisz blok. 

Aby zobaczyć różnicę pomiędzy adresowaniem symbolicznym i 
absolutnym, należy wy ączyć reprezentację symboliczną w 
View>Display>Symbolic Representation.  

Możesz także zmienić szerokość styku wybierając w menu 
Options>Customize w pozycji „Width of adress field” w zak adce 
„LAD/FBD”. Tutaj możesz ustawić szerokość 10 do 24 znaków.  

Więcej informacji znajdziecie w Help>Contents w
pozycjach „Programming Blocks”-programowanie 
bloków, „Creating Logic Blocks” - tworzenie 
bloków, i „Editing Ladder Instructions” – edycja 
instrukcji w schemacie drabinkowym. 



„Program główny 
wykonywany cyklicznie”. 
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A  „Przycisk_1”   
A  „Przycisk_2”   
= „Zielone_swiatlo” 

Programowanie instrukcji OR w STL 

  O „Przycisk_3” 

  O „Przycisk_3” 
  O „Przycisk_4” 
  = „Czerwone_swiatlo” 

W ten sam sposób uzupe nij dalsze instrukcje. 

Zosta a stworzona kompletna funkcja AND. 
Zapisz blok, jeśli żaden z symboli nie jest już
podświetlany na czerwono. 

Symbole będą zaznaczane na czerwono, jeśli np. nie będą
zdefiniowane w liście symbolicznej, lub wystąpi b ąd sk adni. 

Można także wprowadzić bezpośrednio nazwę symboliczną. Kliknij na 
znak ??.? a następnie wybierz w menu Insert-> Symbol. Znajdź w 
liście odpowiedni symbol. Nazwa dodawana jest automatycznie.  

Wybierz Network 1.

Wstaw nową sieć i przejdź do obszaru 
wprowadzania instrukcji.  

Wprowadź O (OR), spację, oraz nazwę
symboliczną „Przycisk_3” (w taki sam 
sposób, jak w instrukcji AND) 

Uzupe nij instrukcje i zapisz blok.  
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Programowanie przerzutnika SR 
Wybierz Network 2  i wstaw nową sieć

 A „Automatyka_ON”  Wprowadź w pierwszej linii instrukcję
      A z oznaczeniem symbolicznym 
                „Automatyka_ON” 

A „Automatyka_ON”  Uzupe nij pozosta e instrukcje. Zapisz 
S „AUTO_ZA ”   blok.  

 A „Reka_ON” 
 R „AUTO_ZA ”

Aby zobaczyć różnicę pomiędzy adresowaniem symbolicznym i absolutnym, 
należy wy ączyć reprezentację symboliczną w View>Display>Symbolic 
Representation.  

A „Przycisk_1” Przyk ad: Adresowanie symboliczne w STL 
 A „Przycisk_2”   
 = „Zielone_Swiatlo”

A I 0.1  Przyk ad: Adresowanie absolutne w STL 
 A  I 0.2 
 = Q 4.0 

Więcej informacji znajdziecie w Help>Contents w
pozycjach „Programming Blocks”-programowanie 
bloków, „Creating Logic Blocks” - tworzenie 
bloków, i „Editing STLInstructions” – edycja 
instrukcji w liście instrukcji. 



„Program główny 
wykonywany cyklicznie”. 
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Kliknij ??.?  i wprowadź nazwę
symboliczną „Przycisk_1”. 
Zatwierdź klawiszem Enter. 

Wprowadź nazwę symboliczną
„Przycisk_2” dla drugiego wejścia.  

Wprowadź nazwę
„Zielone_Swiatlo” dla instrukcji 
przypisania. 
W ten sposób uzyskujesz 
kompletnie stworzoną funkcję
AND. 

Jeśli nie ma żadnych symboli 
wskazywanych na czerwono, 
możesz zapisać blok. 

Symbole będą zaznaczane na czerwono, jeśli np. nie będą
zdefiniowane w liście symbolicznej, lub wystąpi b ąd sk adni. 

Jeśli nie ma żadnych symboli 
wskazywanych na czerwono, 
możesz zapisać blok. 

Symbole będą zaznaczane na czerwono, jeśli np. nie będą
zdefiniowane w liście symbolicznej, lub wystąpi b ąd sk adni. 
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Programowanie funkcji OR w blokach logicznych 

Wprowadź nową sieć

Zaznacz miejsce do wstawienia 
funkcji OR. 

Kliknij ikonkę funkcji OR ( 1) i 
przepisanie (=). 

Dodaj oznaczenia dla styków 
„Przycisk_3” i „Przycisk_4”, a dla 
funkcji przypisania 
„czerwone_swiatlo”.  

Zapisz blok. 

Zapisz blok. 
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Programowanie funkcji zapamiętywania w FBD 

Wybierz Network 2 i dodaj kolejną
sieć. Zaznacz aktualną sieć.

Wyszukaj w katalogu w Bit Logic 
element SR. Kliknij na niego 
dwukrotnie.

Wprowadź nazwy symboliczne funkcji 
SR.  

Zapisz blok. 

AUTO_ZAL 

Automatyka_ON

Reka_ON

Aby zobaczyć różnicę pomiędzy adresowaniem symbolicznym i 
absolutnym, należy wy ączyć reprezentację symboliczną w 
View>Display>Symbolic Representation.  

Możesz także zmienić szerokość styku wybierając w menu 
Options>Customize w pozycji „Address Field Width” w zak adce 
„LAD/FBD”. Tutaj możesz ustawić szerokość 10 do 26 znaków.  

Więcej informacji znajdziecie w Help>Contents w
pozycjach „Programming Blocks”-programowanie 
bloków, „Creating Logic Blocks” - tworzenie 
bloków, i „Editing FBD Statements” – edycja 
instrukcji w schemacie drabinkowym. 
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5.2 Programowanie FB1 w schemacie drabinkowym 

Stworzymy blok funkcyjny sterowania i monitorowania stanu paliwa silnika 
dieslowskiego z użyciem dwóch różnych bloków danych. 

Wszystkie sygna y charakterystyczne dla silnika przekazywane są jako 
parametry bloku funkcyjnego, dlatego też należy je zdefiniować w części 
deklaracyjnej bloku jako parametry wejściowe lub wyjściowe.  

Powinieneś także do tej pory opanować wprowadzanie po ączenia 
szeregowego, równoleg ego i funkcji pamiętania. 

1. Wype nianie tabeli deklaracji parametrów 

Obszar deklaracji zmiennych zawiera okno przeglądu zmiennych (lewa część)
i okno dok adnych informacji (prawa część). 

W oknie przeglądu zmiennych należy kolejno wybrać typ ”IN”, ”OUT” i ”STAT”, 
a następnie zdefiniować zmienne w oknie szczegó owym. 
Zdefiniuj zmienne wed ug rysunków umieszczonych poniżej. Typy zmiennych 
są definiowane za pomocą rozwijanej listy. 

Otwieramy edytor programu i w menu 
View wybieramy sposób prezentacji w 
schemacie drabinkowym LAD. 

W nag ówku znajduje się oznaczenie 
bloku FB1, który zosta  otwarty do 
edycji.  
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Nazwy zmiennych mogą sk adać się
jedynie z liter, cyfr i podkreśleń.
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5.3 Programowanie FB1 w liście instrukcji 

Stworzymy blok funkcyjny sterowania i monitorowania stanu paliwa silnika 
dieslowskiego z użyciem dwóch różnych bloków danych. 

Wszystkie sygna y charakterystyczne dla silnika przekazywane są jako 
parametry bloku funkcyjnego, dlatego też należy je zdefiniować w części 
deklaracyjnej bloku jako parametry wejściowe lub wyjściowe. 

Powinieneś wiedzieć, jak w STEP7 wprowadzić instrukcję AND, lub OR, czy 
też set/reset. 

1. Wype nianie tabeli deklaracji parametrów 

Wprowadź deklaracje w tabeli. Należy wzorując się na poniższych tabelach, w 
odpowiednie komórki wprowadzić nazwę parametru, jego format, a także
komentarz do parametru. Typ parametru można wprowadzić wpisując jego 
nazwę, lub też uruchomić okienko typów prawym klawiszem myszy,  którym 
możemy wybrać typy podstawowe: „Elementary Types”. Jeśli zadeklarujesz 
już wszystkie pola dotyczące zmiennej, zatwierdź to klawiszem ENTER.

Otwieramy edytor programu i w menu 
View wybieramy sposób prezentacji w 
liście instrukcji STL. 

W nag ówku znajduje się oznaczenie 
bloku FB1, który zosta  otwarty do 
edycji.  

Nazwy zmiennych mogą sk adać się
jedynie z liter, cyfr i podkreśleń.

Nazwy zmiennych mogą sk adać się
jedynie z liter, cyfr i podkreśleń.
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Należy zatwierdzić okno dialogowe 
przypisania parametrów lokalnego 
bloku danych. 

Następnie w kolumnie wartości 
aktualnych „Actual Value” w wierszu 
prędkości zadanej („Setpoint Speed”) 
wprowadźmy wartość 1500. W ten 
sposób zdefiniowaliśmy maksymalną
prędkość tego silnika. 
Teraz zapamiętujemy blok i zamykamy
okno edytora. 
W ten sam sposób definiujemy blok 
DB2 („Petrol”) wprowadzając jako 
wartość zadaną prędkości liczbę 1200. 

W tym momencie zakończyliśmy definiowanie bloków potrzebnych do sterowania 
dwoma silnikami za pomocą jednego bloku funkcyjnego. By dodać kolejne silniki 
wystarczy po prostu zdefiniować kolejne bloki danych.  

Następnym naszym krokiem będzie wywo anie bloku FB1 w bloku g ównym OB1. 
By wykonać to w schemacie drabinkowym przeczytaj rozdzia  5.6, w liście 
instrukcji rozdzia  5.7, a w schemacie bloków logicznych rozdzia  5.8. 

Więcej infomacji znajduje się w 
Help>Contents w tematach 
„Programming Blocks” oraz „Creating Data 
Blocks”. 
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Wstaw adresy symboliczne dla wszystkich parametrów użytych dla tej funkcji 
poruszając się po dostępnej liście symbolicznej.  

Wybierając blok „Petrol” 
spowodujemy automatycznie 
powiązanie tego wywo ania bloku 
funkcyjnego FB1 z blokiem danych 
dla silnika benzynowego.  

Wejścia i wyjścia funkcji 
wyświetlane są teraz jako jej 
parametry.  
Zostaną im przypisane 
sygna y charakterystyczne 
dla silnika benzynowego 
„PE_xxx”. 
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Wstaw adresy symboliczne dla wszystkich parametrów użytych dla tej funkcji 
poruszając się po dostępnej liście symbolicznej.  

Wybierając blok „Petrol” 
spowodujemy automatycznie 
powiązanie tego wywo ania bloku 
funkcyjnego FB1 z blokiem danych 
dla silnika benzynowego.  

Wejścia i wyjścia funkcji 
wyświetlane są teraz jako jej 
parametry.  
Zostaną im przypisane 
sygna y charakterystyczne 
dla silnika benzynowego 
„PE_xxx”. 
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 Montaż sterownika 

Aby zamontować modu  na szynie, proszę postępować wg. wskazówek: 

• Do ączyć modu  do ącznika szyny komunikacyjnej 
• Zawiesić modu  i przechylić w dó
• Przymocować modu  dokręcając śrubę u spodu 
• Zamontować pozosta e modu y
• Po zamontowaniu wszystkich modu ów w ożyć kluczyk do CPU. 

Test można też przeprowadzić, jeśli używasz innej konfiguracji sprzętowej niż
pokazana. Należy jednak uważać na prawid owe adresowanie wejść i wyjść.

STEP 7 oferuje wiele możliwości testowych, np. test statusu programu lub test 
zmiennych. 

Więcej informacji o konfiguracji jednostek 
podstawowych uzyskasz w podręczniku 
„S7-300, Hardware and Instalation/Module 
Specifikations” i „S7-400/M7-400  - 
Hardware”. 
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Za ącz teraz na swoim modelu 
testowym oba prze ączniki. 

Na module wejściowym zapalą się
diody wejść I 0.1 i I 0.2. 

Na module wyjściowym zapali się
dioda wyjścia Q 4.0. 

W postaciach graficznych LAD/FBD 
możemy obserwować zmiany stanu 
stosując inne kolory dla różnych 
stanów.  

W języku STL zmiany w uk adzie 
sterowania sygnalizowane są
zmianami wartości w tabeli w 
kolumnach RLO i STA. 

Zdeaktywuj Debug>Monitor i
zamknij okno. 

Następnie w SIMATIC Manager 
zamknij okno „Online”. 

Nie zalecamy ca kowitego adowania obszernych programów do CPU, ponieważ
utrudnia to zdiagnozowanie ewentualnego b ędu z uwagi na zwiększoną ilość
źróde  b ędu. Zalecamy za to, dla lepszej przejrzystości, oddzielne adowanie 
poszczególnych bloków i każdorazowe ich testowanie po za adowaniu. 

Dalsze informacje w Help > 
Contents w rozdzia ach "Debugging" 
i "Testing with Program Status." 
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Tabela zmiennych jest początkowo pusta. Wprowadź nazwy symboli lub 
adresy dla przyk adu „Getting Started” zgodnie z rysunkiem. Pozosta e dane 
zostaną uzupe nione, jeśli zatwierdzisz wprowadzony element klawiszem 
Return. 

Zmień format statusu wszystkich wartości obrotów na format DEC. Kliknij na 
odpowiednią kratkę (strza ka myszy na kolumnie „Monitor Format”) i wybierz 
format DEC. 

Za ączenie tabeli zmiennych w tryb Online 

Zapisz swoją tabele zmiennych. 

Kliknij przycisk ON w oknie "Monitoring 
and Modifying Variables".Zostanie 
stworzone po ączenie Online. W listwie 
statusowej pojawi się napis ONLINE.  

Ustaw kluczyk w pozycji RUN-P (o ile nie 
jest już tak ustawiony). 
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Obserwacja zmiennych 

Modyfikacja zmiennych 

Wprowadź wartość 1500 dla MW2 w kolumnie Modify Value, i dla MW4 
wprowadź 1300. 

Kliknij na Monitor Variable. W 
listwie statusu widoczny jest tryb 
pracy CPU. 

W ącz Przycisk 1 i 2 na wejściach  
sterownika i obserwuj wynik w 
tabeli zmiennych. 

W tabeli zmiennych status wejść
zmienia się z „false” na „true”. 

Przenieś wprowadzone wartości 
do sterownika. 
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Po przes aniu danych do CPU, można zaobserwować wynik porównania. 

Często ze względu na ograniczenia ekranu bardzo obszerna tabela zmiennych 
nie może być pokazana w ca ości. 

Jeśli posiadasz dużą tabelę zmiennych, zalecamy tworzenie za pomocą STEP 7 
kilku tabel zmiennych do programu S7. Tabele te można dopasować dok adnie do 
twoich potrzeb testowych. 

Analogicznie do bloków tabelom zmiennych można przyporządkowywać
indywidualne nazwy symboliczne (np. zamiast VAT1 nazwę OB1_sieć1). 
Przyporządkowanie nazw odbywa się w  tabeli symboli. 

Dalsze informacje znajdują się w Help > 
Contents w rozdzia ach "Debugging" i 
"Testing with the Variable Table." 
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W oknie „Module Information” możesz znaleźć informacje o cechach i 
parametrach twojego CPU. Aby sprawdzić przyczynę trybu pracy STOP 
wybierz zak adkę Diagnostic Buffer.

Ostatnie wydarzenie (nr 1) znajduje się na najwyższej pozycji. Pokazana jest 
przyczyna wystąpienia STOP. Zamknij wszystkie okna, aż do poziomu 
Managera SIMATIC. 

Klawisz „Open Block” 
jest nieaktywny, 
ponieważ przyczyną
trybu STOP nie by
b ąd programu 

Jeśli przyczyną STOP jest b ąd programu, zaznacz wynik wydarzenia i kliknij na 
pole Open .

Blok zostanie otwarty w znanym już oknie edytora programu LAD/STL/FBD, a 
b ędna sieć zostanie zaznaczona. 

Ten rozdzia  kończy przedstawianie tworzenia projektu „Getting Started” od 
momentu jego za ożenia do testowania pracującego sterownika. W następnych 
rozdzia ach pog ębisz swoją wiedzę wykonując przedstawione ćwiczenia. 

Dalsze informacje znajdują się w Help > 
Contents w rozdziale "Calling the Module 
Information." 





kontekstowego.
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8.2 Programowanie funkcji 

W naszym przyk adzie zaprogramujemy funkcję czasową. Funkcja będzie 
dzia ać w ten sposób, iż po za ączeniu silnika (rozdz. 5) za ączony zostanie 
wentylator, który po wy ączeniu silnika będzie pracować jeszcze przez cztery 
sekundy. (Opóźnienie wy ączenia).  

Zgodnie z powyższym należy zadeklarować parametry wejściowe i wyjściowe 
funkcji.  

Otwórzmy edytor programu LAD/STL/FBD. Deklarację parametrów należy
przeprowadzić podobnie, jak przy parametryzacji bloku funkcyjnego (rozdz. 5).  

Wprowadź poniższe parametry: 

Programowanie funkcji czasowej w LAD 

Zaznacz linię wprowadzania 
elementów LAD.  

Znajdź w katalogu funkcji cz on 
czasowy S_OFFDT, i wprowadź go 
do sieci.  

Wprowadź na wejście S styk 
normalnie rozwarty.  

Wprowadź cewkę na wyjście Q.

Programowanie funkcji czasowej w LAD 

Zaznacz linię wprowadzania 
elementów LAD.  

Znajdź w katalogu funkcji cz on 
czasowy S_OFFDT, i wprowadź go 
do sieci.  

Wprowadź na wejście S styk 
normalnie rozwarty.  

Wprowadź cewkę na wyjście Q.
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Zaznacz znaki zapytania i wprowadź w to miejsce nazwę parametru z tabeli 
deklaracyjnej (automatycznie zostanie poprzedzona znakiem # ). 

Na wejście TV wprowadź wartość czasu opóźnienia. Postać wprowadzana 
S5T#4s oznacza iż wprowadzana jest wartość sta a w formacie S5TIME# 
(S5T#) o wielkości 4 sekund.  

Zapamiętaj stworzoną funkcję i zamknij okno.  

Programowanie funkcji czasowej w STL 

Parametr wejściowy „Engine_ON” powoduje 
uruchomienie #Timer_Function. Później trzeba 
będzie stworzoną funkcję FC wywo ać
dwukrotnie w bloku OB1, raz dla silnika 
benzynowego, drugi raz dla silnika Diesla. 
Podczas wywo ania trzeba będzie określić
parametry, które potem można oznaczyć
symbolem w tabeli symbolicznej.

W przypadku programowania w 
postaci STL ustaw kursor na polu 
wprowadzania programu i wpisz obok 
przedstawione instrukcje. 

Zapisz wprowadzoną funkcję i 
zamknij okno edytora.  
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Programowanie funkcji czasowej w FBD 

 W przypadku programowania w FBD ustaw kursor na polu wprowadzania 
 funkcji i stwórz odpowiednią funkcję czasową.

 Zapisz wprowadzoną funkcję i zamknij okno edytora. 

By stworzona funkcja mog a być prawid owo przetwarzana, należy ją wywo ać w 
odpowiednio przyporządkowanym bloku nadrzędnym (np. w OB1).  

Dalsze informacje znajdują się w Help 
>Contents w rozdziale "Calling Reference 
Helps", "The STL, FBD, or LAD Language 
Description", i "Timer Instructions." 
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8.3 Wywo anie funkcji w OB1 

 Wywo anie funkcji FC1 w bloku OB1 wykonuje się tak samo jak we wcześniej 
 stworzonym bloku funkcyjnym. Należy przy wywo ywaniu funkcji określić
 wszystkie jej parametry.  

Jeśli któryś z operandów przypisywanych do parametrów nie posiada nazwy 
symbolicznej, należy uzupe nić to używając tabeli symbolicznej.  

Operant jest fragmentem instrukcji w STEP 7, który 
mówi z czym procesor powinien coś zrobić. Może on 
być w postaci absolutnej lub symbolicznej.  

Otwarty jest aktualnie projekt „Getting 
Started”, lub też projekt stworzony 
samodzielnie. 

Dojdź do folderu Blocks i otwórz blok 
OB1. 

Otwiera się okno edytora 
LAD/STL/FBD.   
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Programowanie wywo ania w STL 

Programowanie wywo ania w FBD 

W przypadku programowania w FBD wejdź w obszar wprowadzania diagramu 
funkcji i operując w katalogu funkcji wprowadź poniżej przedstawione 
elementy.

 Zapisz wprowadzony program i zamknij okno edytora. 

W przypadku programowania 
w STL, wejdź w obszar 
programowania i wprowadź
instrukcje podane obok.  

Zapisz wprowadzony program 
i zamknij okno edytora.  

W naszym przyk adzie zastosowaliśmy wywo anie bezwarunkowe funkcji, tzn. 
każdorazowo funkcja będzie realizowana bez względu na wynik wcześniejszych 
operacji logicznych. 

Można jednak w razie potrzeby realizację FC lub FB uzależnić od pewnych 
warunków np. od jakiegoś wejścia. By zrealizować wywo anie warunkowe należy
ten warunek wprowadzić na wejście EN.  

Dalsze informacje znajdują się w Help >
Contents w rozdzia ach "Calling Reference 
Helps," "The LAD, FBD, or STL Language 
Description," lub"Program Control Instructions." 
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9 Programowanie globalnego bloku danych 

9.1 Zak adanie i otwieranie globalnego bloku danych 

Jeśli ilość wewnętrznych znaczników (merkerów) w CPU (komórki pamięci) nie 
jest wystarczająca do zapamiętania wszystkich danych, pewne wybrane dane 
mogą zostać zarchiwizowane w globalnym bloku danych. 

Dane globalnego bloku danych są dostępne z każdego bloku programowego. 
Lokalny blok danych  jest przyporządkowany określonemu blokowi 
funkcyjnemu, dane dostępne są tylko w tym bloku (por. rozdz. 5.5). 

Zapozna eś się już z programowaniem w LAD, STL i FBD (por. rozdz. 4 i 5) jak 
i programowaniem z wykorzystaniem symboli (por. rozdz. 3). 

Jeśli przeprowadzi eś przyk adowy 
projekt „Getting Started” z rozdzia u
1-7, otwórz go teraz. 

Jeśli nie, za óż nowy projekt w 
SIMATIC Manager za pomocą File > 
„New Project” Wizard . Analogicznie 
do rozdzia u 2.1 nazwij projekt 
„Getting Started Global-DB”. 

Punktem wyjścia w dalszej części 
będzie projekt „Getting Started”. 
Możesz jednakże wykonać każdy
krok również w nowo za ożonym 
projekcie. 

Przejdź do folderu Blocks i otwórz 
go. 

Kliknij prawym przyciskiem myszy na 
prawe pole okna. 



u˝yj przycisku HELP.

z Menu 
kontekstowego



wpisz

kontekstowego
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Przyporządkowanie symboli 

Blokowi danych także możesz 
przyporządkować nazwę
symboliczną.

Otwórz Symbol Table i wprowadź
dla bloku danych DB3 symbol 
„S_Data”. 

Jeśli w rozdziale 4 kopiowa eś tabelę
symboli z przyk adowego projektu 
(zEn01_02_STEP7__STL_1-10, 
zEn01_06_STEP7__LAD_1-10 lub 
zEn01_04_STEP7__FBD_1-10) do 
swojego projektu „Getting Started”, nie 
musisz teraz wprowadzać nowych 
symboli. 

Zapisz tabelę symboli i zamknij 
okno „Symbol Editor”. 

Zamknij też tabelę deklaracji 
zmiennych globalnego bloku 
danych. 

Globalny DB w tabeli deklaracji zmiennych:
Używając View > Data View możesz zmieniać aktualne wartości danych typu INT 
w tabeli globalnego bloku danych (por. rozdz. 5.5). 

Globalny DB w tabeli symboli: 
W przeciwieństwie do lokalnego bloku danych typ danych globalnego DB w tabeli 
symboli jest zawsze adresem absolutnym. W naszym przyk adzie typ danych to 
„DB3”. Dla lokalnego bloku danych na sta e podany jest jako typ danych 
przynależny FB. 

Więcej informacji uzyskasz pod Help > Contents
„Programming Blocks” i „Creating Data Blocks”. 
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10.2 Programowanie FB10 

By wykorzystywać blok FB1 jako wielokrotny należy dla każdego jego 
wywo ania stworzyć w części deklaracyjnej FB10 zmienne statyczne 
(każdorazowo opisane inną nazwą). Jako typ danych należy wybrać FB1.

Wype nienie tabeli deklaracji 

Otwarte jest okno edytora programowego. Zadeklaruj do wywo ania FB1
 następujące zmienne.

Zadeklarowane bloki wielokrotne znajdą
się w efekcie naszych dzia ań w katalogu 
elementów programowych pod nazwą
"Multiple Instances." 

Zadeklarowane bloki wielokrotne znajdą
się w efekcie naszych dzia ań w katalogu 
elementów programowych pod nazwą
"Multiple Instances." 
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Wprowadź kolejną sieć i zaprogramuj po ączenie szeregowe odpowiednio je 
adresując. Następnie zapisz program i wyjdź z bloku programowego.  

Programowanie FB10 w STL

Zmienne lokalne 
("PE_Setpoint_Reached" i  
"DE_Setpoint_Reached") przypisane 
zostaną do parametru wyjściowego 
"Setpoint_Reached," który będzie 
móg  być wykorzystany w OB1. 

W przypadku programowania w 
postaci STL wstaw nowy segment, 
ustaw kursor na polu wprowadzania 
programu, i wpisz obok 
przedstawione instrukcje. 

Zapisz wprowadzony program i 
zamknij blok.  
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Zmień aktualną wartość dla silnika Diesla na 1300, zapisz zmiany i zamknij 
blok.  

W postaci deklaracyjnej tabeli widoczne są tylko ogólne dane dla poszczególnych 
silników.  

Zmienne wewnętrzne bloku FB1 posiadają swoje nazwy symboliczne np. 
„Eingine_On”. Dostęp do nich jest możliwy dzięki podaniu pe nej nazwy np.: 
"Petrol_Engine.Switch_On." 

Dalsze informacje znajdują się w 
Help > Contents w rozdziale 
"Programming Blocks" i "Creating 
Data Blocks." 
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10.4 Wywo anie FB10 w OB1 

W naszym przyk adzie blok FB10 zostanie wywo any w bloku OB1. Zasada 
budowy i funkcjonowania tego wywo ania jest identyczna, jak przy zrobionym 
już wywo aniu bloku FB1 (patrz rozdz. 5.6). W rozdziale 5.6 do 
zaprogramowania użyliśmy wywo ań w sieciach 4 i 5.  

 Definicja nazw symbolicznych 

Otwarte jest okno edytora programu. Otwórz tabelę symboli używając w menu 
Options > Symbol Table i wprowadź oznaczenia symboliczne dla bloków 
FB10 i DB10.  
Zamknij tabelę i okno symboli. 

 Stworzenie wywo ania bloku 

Otwórz blok OB1 w projekcie, w 
którym w aśnie zaprogramowa eś
blok FB10.  

Jeśli w rozdziale 4 skopiowa eś
przyk adową tabelę symboli do Twojego 
projektu, nie trzeba ich teraz ponownie 
definiować.

Wprowadź na końcu bloku nową sieć,
i uzupe nij go o wywo anie bloku 
FB10 („Engines”). 
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Wywo anie w FBD 

Jeśli pos ugujemy się postacią FBD, w nowo stworzonej sieci wejdź na pole 
wprowadzania programu i wpisz poniżej podane instrukcje. Użyj w tym celu 
element katalogu FB Blocks>FB10 Engines.

Usuń w sieci 4 i 5 dotychczasowe wywo ania bloku FB1. Teraz blok ten 
wywo ywany jest tylko w FB10.  

Zapamiętaj program i zamknij blok.  

Jeśli potrzebne by oby sterowanie kolejnych silników, postępowanie by oby
identyczne, też w tym celu moglibyśmy użyć bloku FB10.  
Należa oby zadeklarować w tabeli deklaracji bloku FB10 dalsze silniki i wywo ać w 
nim kolejne bloki FB1. W tabeli symboli należa oby dodać adresację i oznaczenia 
dla nowych silników. 

Dalsze informacje znajdują się w Help > 
Contents w rozdziale "Calling References 
Helps," "The STL, FBD, or LAD 
Language Description," i "Program Control 
Instructions." 
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11 Konfiguracja systemu rozproszonego 

11.1 Tworzenie systemu zdecentralizowanego przy użyciu sieci 
PROFIBUS DP 

Standardowo w centralnych systemach sterowania wszelkie sygna y z 
czujników oraz do elementów wykonawczych przekazywane są z modu ów 
sterownika centralnego. Przy większych odleg ościach pociąga to za sobą
wysokie koszty okablowania. 

Stosując system rozproszony, umieszczając modu y wejść i wyjść w pobliżu
czujników i elementów wykonawczych, ogranicza się nak ad pracy i koszty 
okablowania. Po ączenie pomiędzy modu ami i jednostką centralną następuje 
poprzez sieć PROFIBUS-DP.  

Dotychczas poznaliśmy programowanie sterownika w systemie centralnym. 
Programowanie tego typu systemów i systemu zdecentralizowanego jest 
identyczne. Podobnie również odbywa się konfiguracja.  

Pomocna by aby w dalszej pracy znajomość metod konfiguracji uk adów 
centralnych (patrz rozdz. 2.1 i 6). 



kontekstowego
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Konfiguracja stacji 

Zaznacz folder SIMATIC 300-Station 
i kliknij dwukrotnie Hardware. 
Otwiera się edytor konfiguracji.  

CPU 315-2 DP jest widoczne w raku. 
Jeśli trzeba, uaktywnij katalog 
elementów sterownika klikając ikonkę
na listwie narzędziowej, lub 
wybierając w menu View > Hardware 
Catalog. 

Wprowadź na pozycję 1 zasilacz 
PS307 2A. 

Na pozycję 4 wprowadź modu  wejść
DI32xDC24V, na pozycję 5 modu
wyjść DO32xDC24V/0,5A.
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Konfiguracja DP-Master 

Zaznacz na poz. 2.1 DP-Master i 
wprowadź DP-master system. 

Znajdź w katalogu modu B-16DI i 
wprowadź go do sieci (puszczając na 
przerywaną linię). 

W oknie „Properties” można
zadeklarować nową sieć oraz adres 
wprowadzanego modu u.  

Zatwierdź wprowadzony adres 1.  

Wykonaj te same operacje dla 
modu u B-16DO.  

Tym razem adres zostanie 
zaproponowany automatycznie. 
Zatwierdź ustawienia przyciskiem 
OK.  

Wszystkie obiekty skonfigurowane jako 
uczestnicy sieci DP można dowolnie 
przemieszczać w ramach tej sieci.  
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Wprowadź do sieci modu  interfejsu 
IM153 (modu  ET200M) i zatwierdź
zaproponowany adres klawiszem OK.  

Kliknij na sieci ET200M. W dolnej 
części okna ukaże się tabela 
konfiguracyjna modu u ET200M. 
Wybierz pozycję 4.  

Do ET200M można do ożyć dalsze 
modu y. Weźmy np. modu
DI32xDC24V i wprowadźmy na 
pozycję 4.  

W naszym przyk adzie przyjęte zostaną
adresy zaproponowane przez system. 
Można je jednak w razie potrzeby 
zmienić.

Należy zwracać uwagę z jakiego 
foldera dok adane są modu y. Np. dla 
systemu ET200M należy korzystać z 
folderu ET200M.   
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 Zmiana adresów uczestników sieci 

W naszym przyk adzie zmiana adresu 
nie jest konieczna. W praktyce jednak 
może być czasem przydatna. 

Zaznaczając po kolei wszystkich 
uczestników sieci sprawdź ich 
adresy. System zapewni  ich 
niepowtarzalność.

Za óżmy, że chcemy zmienić adresy 
w ET200M: 

Zaznacz modu  na pozycji 4 
DO32xDC24V/0,5A.  

Zmień w oknie „Properties” 
ustawienie adresu z 6 na 12, i 
zatwierdź ustawienia klawiszem OK. 

Na zakończenie zapisz i skompiluj 
konfigurację (save and compile).  

Zamknij okno.  

Przeprowadzenie funkcji „save and compile” powoduje 
jednocześnie sprawdzenie rozk adu modu ów. W przypadku 
bezb ędnej konfiguracji stworzone zostaną dane systemowe i 
będzie można przes ać konfigurację do sterownika. 
W przypadku wykorzystania jedynie funkcji zabezpieczenia 
(save), może zostać zapamiętana także b ędna konfiguracja. 
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Opcjonalnie: Projektowanie sieci 

Konfigurację systemu rozproszonego 
można także przeprowadzić
wykonując projekt sieci.  

Kliknij dwukrotnie na sieć PROFIBUS 
w SIMATIC Manager. 

Otwiera się okno NETPRO. 

Możemy teraz dodawać z katalogu 
dalszych uczestników sieci (DP-
Slave).  

Kliknij dwukrotnie na dowolny 
element. Otwarte zostaje okno 
konfiguracji sprzętowej.   

Za pomocą funkcji Station > Consistency Check (w oknie "Configuring 
Hardware") lub Network > Consistency Check (w oknie "Configuring Networks") 
można sprawdzić poprawność wykonania konfiguracji sieciowej przed jej 
zabezpieczeniem. W przypadku wykrycia b ędów zostaną podane ich miejsca 
oraz  poprawne rozwiązania. 

Dalsze informacje znajdują się w Help > Contents 
w rozdziale "Configuring the Hardware" i 
"Configuring the Distributed I/O." 
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Gratulacje! 

Znasz już sposób tworzenia projektu w systemie STEP7. Znasz sposób zak adania i 
konfigurowania stacji, oraz rodzaje i sposoby tworzenia bloków programowych, a 
także inne funkcje programu np. postać symboliczną czy też monitorowanie dzia ania 
programu.  
W przypadku wątpliwości, jakie mogą powstać przy tworzeniu kolejnych projektów 
polecamy korzystanie z bogatego systemu pomocy.  
Jeśli chcesz pog ębić swoją wiedzę na temat STEP7 zalecamy wzięcie udzia u w 
prowadzonych szkoleniach, a także rozszerzanie wiedzy o szczegó y zawarte w 
dokumentacji do systemu SIMATIC S7. 

Życzymy powodzenia w tworzeniu dalszych projektów. 
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Notatki
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